debian 6 stable perl problem

Машинката е debian 6 stable , като днес реших да и ъпдейтна perl-а с през cpan , upgrade . Фен съм на ъпгрейдите но този път случих на камък 🙂 след ъпгрейда видях грешка при ъпдейт-а на mrtg-то:


Constant subroutine SNMP_Session::AF_INET6 redefined at
/usr/share/perl/5.10/Exporter.pm line 67.
at /usr/share/perl5/SNMP_Session.pm line 149
Prototype mismatch: sub SNMP_Session::AF_INET6 () vs none at
/usr/share/perl/5.10/Exporter.pm line 67.
at /usr/share/perl5/SNMP_Session.pm line 149
Constant subroutine SNMP_Session::PF_INET6 redefined at
/usr/share/perl/5.10/Exporter.pm line 67.

Самия демон си върви и си работи но плюе тази досадна грешка. След малко ровене в нета открих че и други са имали този проблем след ъпдейт
но не открих конкретен отговор. Реших че ако ъпдейтна perl, perl-base , perl-modules ще се оправи проблема, но
установих че или трябва да го направя ръчно през някой tar.gz или трябва да мина на debian unstable. Нито едното не ми хареса 🙂
Реших че по-добрия вариянт е да ъпдейтна mrtg-то като махна debian-ския пакет и компилирам на ново от сайта на Тоби Ойтикер.
Проблема изчезна, вече имам ъпдейтнат perl и работещ с най-новата си версия mrtg